Обновление / загрузка классификаторов банка из zip-архива для давно не обновлявшихся баз 1С

Публикация № 1557117 25.11.21

Бухгалтерский учет - Банковские операции

Бухгалтерия программный код загрузка Классификатора банка для старых версий начинающего программиста помощь бухгалтеру

И старые версии 1С:Бухгалтерия - имеют право на новые классификаторы банков!!!))

1С:Бухгалтерия,например, версии 3.70.50 и до 80-х версий - распознавание зашифрованных банковских счетов  у них старенькое и, соответственно, обработка, вшитая в типовую 1С:Бухгалтерию,- так же старенькая....

А с начала этого (2021г) - бюджетники (налоговая и иже с ними) перешли на новые счета в своих банках (у них поменялся корр.счет и сам расчетный счет)...

Так вот, если у Вас типовая 1С:Бухгалтерия застыла в старых версиях и пока НИКАК не может обновиться, например, по причине  сильной переписки типовой конфигурации, то стандартными обработками, вшитыми в конфигурацию, - невозможно обновить Классификатор банков, а следовательно в бухгалтерии - не смогут создать новые расчетные банковские счета для контрагентов, таким образом бухгалтерам придется вручную в клиент банке рисовать платежки...

Здесь на Инфостарте есть парочка готовых обработок, которые могут загружать Классификаторы Банков не только с сайта 1С, но с РБК и др. Я выбрала вот эту: //katalog.elrey-uslugi.ru/public/1208625/

Но оказалось, что данная обработка не может помочь мне загрузить из интернета ни с сайта 1с ни с сайта РБК....может потому что у меня серверный вариант базы, но пробовала и на файловой - нет, нужно дописать код корректной загрузки с сайта, если кто шарит, то дорисуйте - будет здорово.

Меня вполне устраивала загрузка не с сайта, а напрямую из zip-архива на компьютере (просто я заранее залила на комп архивы из 1с и с РБК - см. скрин как из 1С слить архив банка:

 

 

). Но здесь появилась следующая проблема: скаченная обработка обращается к готовой ТИПОВОЙ обработке "ЗагрузкаКлассификатораБанков"......а у меня конфигурация старая и переписанная - у меня изначально в конфигурации эта обработка старая и, конечно, она не будет работать!....какой тогда смысл?

Нашла выход: установила свежую версию демо 1С:Бухгалтерия - и по кусочкам затягивала в исходную скачанную обработку - программный код из типовой обработки "ЗагрузкаКлассификатораБанков" свежей версии 1сБух. Все четко! Получилось загрузить из архива Классификатор Банков!!!! Ураааа!!!

Но, внутри моей версии 1С: 1) старый распознаватель расшифровки банковских счетов; 2) в справочнике Классификатор Банков - не хватает нового реквизита БИКРКЦ.....................ну и ладно, так как конфигурация у нас все равно уже переписанная, то чуток нашего кода ей уже не повредит))

Итак, начнем: в нашей конфигурации открываем справочник "КлассификаторБанков" и добавляем новый реквизит БИКРКЦ, тип которого ссылка на этот же справочник (см. скрин)

 

 

Далее, открываем в конфигураторе справочник"БанковскиеСчета", открываем форму Элемента, далее модуль формы, находим Процедуру ПередЗаписью(), там идет обращение к другой процедуре БанковскиеСчетаФормыКлиент.ПередЗаписью(Объект.НомерСчета, БИКБанка, Объект.Ссылка, Отказ), правая клавиша мышки на эту процедуру и "Перейти к определению", нас переносит в Общий модуль на следующую процедуру ПередЗаписью(НомерСчета, БИКБанка, СсылкаНаОбъект, Отказ) Экспорт, внутри этой процедуры - есть обращение к функции БанковскиеПравила.ЭтоКорректныйСчетБанкаРФ(НомерСчета, БИКБанка), вновь кликаем по ней правой кнопкой мышки-"Перейти к определению"-летим внутрь этой функции, а внутри нее - еще одно обращение к другой функции ЭтоКорректныйСчетБанкаРФ(НомерСчета, КодБанка) Экспорт, летим вновь внутрь этой и видим ссылку еще на одну функцию ПроверитьКонтрольныйКлючВНомереБанковскогоСчета(НомерСчета, КодБанка), прыгаем в нее, и вуа ля! то, что мы искали!!! 

Теперь все, что находится внутри функции ПроверитьКонтрольныйКлючВНомереБанковскогоСчета(НомерСчета, КодБанка) - затираем (ставим // вначале каждой строки), и копируйте вот отсюда код и вставляйте его внутрь функции:

	// Письмо ЦБР от 8 сентября 1997 г. N 515
	
	Если СтрокаСоответствуетФормату = Неопределено Тогда
		СтрокаСоответствуетФормату = СтрокаСоответствуетФорматуБанковскогоСчета(НомерСчета);
	КонецЕсли;
	
	Если Не СтрокаСоответствуетФормату Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если Не ПроверитьДлинуБИК(БИК) Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если Не ПроверитьДлинуНомераСчета(НомерСчета) Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если ЭтоБИКТОФК(БИК) И ЭтоКазначейскийСчет(НомерСчета) Тогда
		// Ключевание не предусмотрено.
		Возврат Истина;
	КонецЕсли;
	
	// 2. Для расчета контрольного ключа используется совокупность двух реквизитов - 
	// условного номера РКЦ (если лицевой счет открыт в РКЦ)
	// или кредитной организации (если лицевой счет открыт в кредитной организации)
	// и номера лицевого счета.
	
	// 3. Значение трехзначного условного номера РКЦ соответствует разрядам 5 и 6 
	// банковского идентификационного кода (БИК), дополненным слева нулем до трех разрядов.
	// 4. Значение условного номера кредитной организации соответствует разрядам 7, 8 и 9 БИК.
	
	Если ЭтоОтделениеЦентральногоБанка(БИК) Тогда
		УсловныйНомер = "0" + Сред(БИК, 5, 2);
	Иначе
		УсловныйНомер = Сред(БИК, 7, 3);
	КонецЕсли;
	
	Если Не СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(УсловныйНомер) Тогда
		Возврат Ложь;
	КонецЕсли;
	
	//        Контрольный ключ (К)
	//        ^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^88;   Порядковые номера разрядов ^72;^72;^72;^72;^72;^72;^88;
	//   ^84;^72;_16;^72;_16;^72;^88; ^84;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;_24;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;^88;  ^74;
	//   ^74;1^74;2^74;3^74; ^74;1^74;2^74;3^74;4^74;5^74;6^74;7^74;8^74;9^74;10^74;11^74;12^74;13^74;14^74;15^74;16^74;17^74;18^74;19^74;20^74;<^72;^96;
	//   ^92;^72;_24;^72;_24;^72;^96; ^92;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;^96;
	//   ^74;     ^74; ^74;        Номер лицевого счета                      ^74;
	//   ^74;     ^74; ^92;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^96;
	//   ^74;     ^92;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;
	//   ^74;  Условный номер РКЦ или кредитной организации
	//   ^92;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;
	
	ВсеСимволы = УсловныйНомер + НомерСчета;
	ТипЧисло   = Новый ОписаниеТипов("Число", , , Новый КвалификаторыЧисла(1, 0, ДопустимыйЗнак.Неотрицательный));
	ПроверяемыйНаборЦифр = Новый Массив(23);
	Для НомерСимвола = 1 По 23 Цикл
		Цифра = ТипЧисло.ПривестиЗначение(Сред(ВсеСимволы, НомерСимвола, 1));
		ПроверяемыйНаборЦифр[НомерСимвола-1] = Цифра;
	КонецЦикла;
	
	// 8. При наличии алфавитного значения в 6-ом разряде лицевого счета 
	// (в случае использования клиринговой валюты) данный символ заменяется на соответствующую цифру:

	// ^84;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;_16;^72;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;^88;
	// ^74;Допустимое алфавитное значение 6-го разряда^74; А^74;В^74;С^74;Е^74;Н^74;К^74;М^74;Р^74;Т^74;Х^74;
	// ^74;номера лицевого счета                      ^74;  ^74; ^74; ^74; ^74; ^74; ^74; ^74; ^74; ^74; ^74;
	// _00;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;_32;^72;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_08;
	// ^74;Соответствующая цифра                      ^74; 0^74;1^74;2^74;3^74;4^74;5^74;6^74;7^74;8^74;9^74;
	// ^92;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;^72;_24;^72;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;^96;

	// После выполнения замены расчет и проверка значения контрольного ключа производится в соответствии с п. 6 и п. 7.
	
	АлфавитныйСимвол = Сред(НомерСчета, 6, 1);
	Если Не СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(АлфавитныйСимвол) Тогда
		ЦифраШестогоРазряда = СтрНайти(ДопустимыеАлфавитныеСимволыНомераБанковскогоСчета(), АлфавитныйСимвол);
		Если ЦифраШестогоРазряда = Неопределено Тогда
			Возврат Ложь;
		КонецЕсли;
		ЦифраШестогоРазряда = ЦифраШестогоРазряда - 1;
		ПроверяемыйНаборЦифр[3+6] = ЦифраШестогоРазряда;
	КонецЕсли;
		
	// 5. Контрольный ключ рассчитывается с использованием весовых коэффициентов,
	// устанавливаемых каждому разряду.

	//                                 Порядковые номера разрядов ^72;^72;^72;^72;^72;^72;^88;
	//    ^84;^72;_16;^72;_16;^72;^88; ^84;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;_16;^72;^72;^88;  ^74;
	//    ^74;1^74;2^74;3^74; ^74;1^74;2^74;3^74;4^74;5^74;6^74;7^74;8^74;9^74;10^74;11^74;12^74;13^74;14^74;15^74;16^74;17^74;18^74;19^74;20^74;<^72;^96;
	//    _00;^72;_32;^72;_32;^72;_08; _00;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_32;^72;^72;_08;
	// ^84;^72;>^74;7^74;1^74;3^74; ^74;7^74;1^74;3^74;7^74;1^74;3^74;7^74;1^74;3^74; 7^74; 1^74; 3^74; 7^74; 1^74; 3^74; 7^74; 1^74; 3^74; 7^74; 1^74;
	// ^74;  ^92;^72;_24;^72;_24;^72;^96; ^92;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;_24;^72;^72;^96;
	// ^74;
	// ^92;^72;^72; Весовые коэффициенты
	
	ВесовыеКоэффициенты = Новый Массив;
	ВесовыеКоэффициенты.Добавить(7);
	ВесовыеКоэффициенты.Добавить(1);
	ВесовыеКоэффициенты.Добавить(3);
	
	// 7. Алгоритм проверки правильности расчета контрольного ключа:
	// 7.1. Рассчитываются произведения значений разрядов на соответствующие весовые коэффициенты 
	// с учетом контрольного ключа.
	// 7.2. Рассчитывается сумма младших разрядов полученных произведений.
	
	Сумма = 0;
	Для Разряд = 0 По 22 Цикл
		ИндексВесовогоКоэффициента = Разряд % 3;//3%3=0, 4%3=1, 5%3=2
		ВесовойКоэффициент = ВесовыеКоэффициенты[ИндексВесовогоКоэффициента];
		Произведение  = ПроверяемыйНаборЦифр[Разряд] * ВесовойКоэффициент;
		МладшийРазряд = Произведение % 10;
		Сумма = Сумма + МладшийРазряд;
	КонецЦикла;
	
	// При получении суммы, кратной 10 (младший разряд равен 0), 
	// значение контрольного ключа считается верным.

	Возврат Сумма % 10 = 0;
	
//******************************************

новый код обращается еще к двум функциям, которых в старой конфигурации нету, поэтому прямо сразу после нашей измененной функции  ПроверитьКонтрольныйКлючВНомереБанковскогоСчета(НомерСчета, КодБанка), копируем и вставляем вот эти пару функций:

Функция ЭтоБИКТОФК(КодБанка) Экспорт  
	
	ПервыеЦифрыБИК = Лев(КодБанка, 2);
	
	Результат = ПроверитьДлинуБИК(КодБанка)
		И (ПервыеЦифрыБИК = "00" Или ПервыеЦифрыБИК = "01" Или ПервыеЦифрыБИК = "02");
	
	Возврат Результат;
	
КонецФункции

Функция ЭтоКазначейскийСчет(НомерСчета) Экспорт
	
	Возврат СтрНачинаетсяС(НомерСчета, "0");
	
КонецФункции

Все, жмите F7 и запускайте пользовательский режим. Откройте мою внешнюю обработку "Загрузка классификаторов банка" - выбирайте ТОЛЬКО из файла (предварительно скачайте эти файлы: хоть с РБК, хоть с 1С), укажите путь - где находится ваш zip-архив, жмите кнопку "Загрузить" - все загрузится.

 

 

Далее в клиента вбиваете новый вид банковского счета - и замечательно проходит проверка и записывается банковский счет!

 

 

п.с. специально не стала убирать переключатель на загрузку с сайта - возможно, что кто-нибудь набросает рабочий код на загрузку с сайта, и будет вообще красота!)

***

п.с. тестировалась данная обработка на ЗУП редакции 3.0.70.50 - работает! на редакции 3.0.88.22 - летает!) а с последнего релиза на сегодня 3.0.105.31 - были взяты архивы Классификаторов Банка на сайте ИТС.

Скачать файлы

Наименование Файл Версия Размер
Обновление/Загрузка классификаторов банка из zip-архива для "ДавноНеОбновлявшихся1с":

.epf 16,22Kb
0
.epf 16,22Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Конвертация любых адресов, написанных в свободной форме, к ФИАС Промо

Универсальные обработки Классификаторы v8 1cv8.cf Россия Абонемент ($m)

Допустим у нас есть база с адресами клиентов, и написаны они могут быть как душе угодно. С опечатками, без индексов, без разделителей, в совершенно любом формате. Вот было бы здорово иметь функцию, которая одним нажатием кнопки преобразует любую белиберду к строгому представлению адреса по ФИАС? Восстановит индекс, исправит опечатки и вернёт на 100% валидный адрес. Для всех, кто мечтательно сказал "ДА!", выкладываю данную обработку.

2 стартмани

30.06.2020    8046    70    XilDen    15    

Исправление устаревших адресов в ЗУП 3.1

Классификаторы v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Вспомогательная обработка для запуска типового регламентного задания "Исправление устаревших адресов".

1 стартмани

08.04.2021    2531    13    Margo462    1    

Настройка оплаты по Системе Быстрых Платежей (СБП) через QR-код (на примере Газпромбанка)

Банковские операции Оптовая торговля v8 1cv8.cf БУ УУ Абонемент ($m)

Обработка включает в себя механизм регистрации организации в СБП (Юр. лицо, счет, ТСП), запрос ссылки на оплату по выбранному нами договору и преобразование ее в QR-код. Клиенту остается только считать его и оплатить. После чего банк присылает нам платежки, где в назначении платежа указан договор, по которому была оплата, дата, плательщик. Предварительно нужно заключить договор с банком.

2 стартмани

30.03.2021    6619    40    pv94384    18    

Загрузка классификатора банков РФ 2021 г. в УТ 10.3, БП 2.0

Банковские операции Классификаторы v8 КА1 БП2.0 УТ10 УПП1 Россия Абонемент ($m)

Внешняя обработка "Загрузка классификатора банков РФ" для БП 2.х , УТ 10.х, КА 1.х , УПП 1.3.х из нового формата классификатора БИК".

1 стартмани

21.01.2021    11067    200    darminov    7    

Загрузка реестра платежей физических лиц из Сбербанка бизнес онлайн Промо

Обмен с банком Банковские операции Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка загружает реестры платежей Сбербанка Бизнес Онлайн в документ "Операции по платежным картам".

1 стартмани

08.07.2019    19512    81    Poyarkov696    16    

Загрузка банков для Бухгалтерии 2.0, УТ 10, КА 1.1, УПП 1.3 из нового формата классификатора БИК

Банковские операции Классификаторы v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Внешняя обработка "Загрузка классификатора банков" для БП 2.х , УТ 10.х, КА 1.х , УПП 1.3.х из нового формата классификатора БИК".

5 стартмани

14.01.2021    13180    175    Torin    21    

Автоматическая загрузка выписок в 1С из клиент банка

Банковские операции Обмен с банком v8 УНФ БГУ БП3.0 БАУ Россия БУ Абонемент ($m)

Загружает выписки в 1с через электронную почту высланные банком.

2 стартмани

06.08.2020    9649    47    user1209971    26    

Заполнение банковских выписок. БП 3.0

Банковские операции Обмен с банком v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данное расширение предназначено для автоматического заполнения реквизитов в выписках из банка. Возможно заполнение любых реквизитов документов "Поступление на расчетный счет" и "Списание с расчетного счета".

1 стартмани

04.08.2020    5350    44    Tash.B    25    

Модуль обмена с QIWI Промо

Банковские операции WEB v8 1cv8.cf УУ Абонемент ($m)

Компании, которые используют систему моментальных платежей QIWI, ценят ее за удобство по скорости выплат и для платежей по запросу. Но такие переводы сложны для учета, а при большом объеме проводимых операций отнимают много времени и превращаются в дополнительную головную боль. Мы сотрудничали с компаниями, которые отправляют большое количество платеже на QIWI, и часто слышали боль бухгалтеров о том, как им сложно работать с такими переводами. Поэтому мы автоматизировали выплаты через QIWI в 1С и создали модуль интеграции 1С c API QIWI Wallet и QIWI TopUp.

5 стартмани

25.05.2020    8538    0    Neti    10    

Автозагрузка банковских выписок (БП 3.0)

Банковские операции Обмен с банком v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение позволяет автоматизировать загрузку банковских выписок в программу 1С:Бухгалтерия предприятия, ред. 3.0. При начальной настройке создается регламентное задание. Период срабатывания регламентного задания в дальнейшем можно поменять в консоли заданий. Требуется указать каталог, из которого нужно загружать банковские выписки.

1 стартмани

06.04.2020    9981    10    primat    15    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    25565    125    etmarket    53    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет Промо

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    23909    10    r.resh39    7    

Загрузка из Клиент-банка, автоматическое заполнение договора и счета на оплату

Обмен с банком Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Учим Клиент-банк «читать» Назначение платежа из файла загрузки. Как правило, текст содержит достаточно информации для поиска договора контрагента и счета на оплату.

2 стартмани

11.12.2019    9639    50    suvig    39    

Загрузка курсов валют на клиенте

БСП (Библиотека стандартных подсистем) Обработка справочников WEB Банковские операции v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение загрузки курсов валют НаКлиенте. Адаптивность стандартной обработки "ЗагрузитьКурсыВалют" для конфигураций, использующих БСП.

1 стартмани

07.12.2019    7528    8    logarifm    4    

1С:Деньги - Автоматическое заполнение расходов по QR-кодам чеков с помощью API ФНС

Обработка документов WEB Банковские операции Кассовые операции Банковские операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

UPDATE 2020.11 Учтено новое API взаимодействия с серверами проверки чеков ФНС. Реализована верификация по номеру телефона и кода из SMS. Обработка поможет сократить время на ввод данных о расходах в 1С:Деньги. Достаточно отсканировать QR-код чека смартфоном, с предустановленным официальным приложением проверки чеков от ФНС. Данные чека будут загружены в базу из данных электронного чека, которые хранятся на серверах ФНС. Обработка протестирована на последнем релизе 2.0.40.12.

1 стартмани

28.07.2019    14013    58    1sig    29    

Загрузка отчетов банка по эквайрингу в формате Excel (xls) (УТ11.4, КА2.4)

Загрузка и выгрузка в Excel Банковские операции Банковские операции v8 УТ11 КА2 Россия БУ Абонемент ($m)

За основу была взята обработка с ИС. Но мне требовалось загрузить данные в КА2.4 и структура файла Excel была другой.

1 стартмани

01.07.2019    7169    68    dachnik    13    

Групповая печать чеков из банковской выписки (БП 3.0)

Пакетная печать Банковские операции Банковские операции v8 v8::БУ БП3.0 БУ Абонемент ($m)

Обработка для групповой печати чеков ККМ, загруженных из банковской выписки. На основании документа Поступление на расчетный счет от физических лиц.

3 стартмани

18.06.2019    13920    53    Doloris0    29    

Исправление банковских выписок

Банковские операции Обработка документов Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка для автоматизации исправления отдельных документов после загрузки выписки банка.

5 стартмани

21.05.2019    8790    12    UmBu    4    

Выгрузка реестра зарплаты в ГазПромБанк ЗУП 2.5 c ведущими нулями Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Корректно выгружает в текстовый формат поля, начинающиеся на НОЛЬ (Например, серии паспортов вида 0803)

5 стартмани

16.05.2016    38384    16    asher72    1    

Загрузка документов Отчет банка по эквайрингу в УТ 11.4 из Excel (Сбербанк)

Обработка документов Банковские операции Загрузка и выгрузка в Excel Обмен с банком Банковские операции v8 УТ11 Россия УУ Абонемент ($m)

Обработка производит загрузку документов Отчет банка по эквайрингу из файла Excel, предоставляемого Сбербанком.

1 стартмани

10.10.2018    13670    83    C0mmander_Alex    13    

Загрузка табличной части документов "Ведомость в банк" или "Ведомость в кассу". ЗУП 3.1 из xls файла.

Обработка документов Загрузка и выгрузка в Excel Банковские операции Зарплата Кассовые операции Банковские операции Зарплата Кассовые операции v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Загрузка \ заполнение табличной части документов "Ведомость в банк" "Ведомость на счета" или "Ведомость в кассу" ЗУП 3.1 из xls файла. Для работы обработки Excel устанавливать не надо. Работает во всех клиентах и вариантах работы, клиент-серверном, файловом и web.

2 стартмани

14.09.2018    13972    136    kg2    37    

Формирование платежных поручений на заданную в поступлениях товаров дату Промо

Обработка документов Банковские операции Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данная обработка предназначена для автоматического формирования платежных поручений на выбранный день на основании документов "Поступление товаров и услуг" и "Счета от поставщиков". Для определения срока оплаты документов используется "Срок оплаты", указанный в документах. Предполагается, что эти документы еще не оплачивались. При этом, если есть несколько документов от поставщика с одним договором, которые необходимо оплатить в один день, будет создано одно платежное поручение, в назначении которого будут перечислены все оплачиваемые документы.

8 стартмани

09.11.2016    28883    24    INTECH1    12    

[Расширение] Клиент-Банк. Выбор документов перед загрузкой в УТ 11.4

Обмен с банком Банковские операции Банковские операции v8 УТ11 УУ Абонемент ($m)

Данное расширение позволяет отметить галочкой нужные документы из файла выгрузки банк-клиента и загрузить только их, не создавая лишние документы.

2 стартмани

24.07.2018    16065    155    ipetrochenko    53    

Выгрузка из ЗУП 3.1 в БП 2.0 документов на выплату зарплаты, отражения в учете. (Отражение зарплаты в бухучете, ведомость на выплату в банк, в кассу, через раздатчика, перечислением)

Перенос данных из 1C8 в 1C8 Банковские операции Зарплата Управление персоналом (HRM) Банковские операции Зарплата v8 БП2.0 ЗУП3.x БУ Абонемент ($m)

Позволит без труда выгрузить документы по отражению зарплаты и ведомости на выплату зарплаты из "Зарплата и Управление персоналом 3.1" в "Бухгалтерия предприятия 2.0"

3 стартмани

10.07.2018    21145    169    Redinternational    11    

ДиректБанк: автоматическая загрузка и разбор банковских выписок по расписанию для Бухгалтерии предприятия 3.0

Банковские операции Обмен с банком Банковские операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка предназначена для автоматической загрузки по расписанию выписок по расчетному счету из сервиса Директ Банк, без использования цифровой подписи и СМС. После загрузки делает автоматический разбор полученной выписки - создает документы "Списание с расчетного счета", "Поступление на расчетный счет", при необходимости добавляет в справочник новых контрагентов.

3 стартмани

27.06.2018    62783    121    uno-c    158    

Экономим время на ввод операций в 1С: Деньги

Внешние источники данных Обработка документов Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы Абонемент ($m)

Рабочее решение автоматического создания операций в 1С: Деньги. Основано на анализе СМС.

1 стартмани

14.05.2018    18932    17    vsbronnikov    29    

Обработки (Формата обмена) для загрузки платежных поручений в 1С 8.3 Бухгалтерия для Украины 2.0 (DBF, XML, CSV)

Банковские операции Обмен с банком Файловые протоколы обмена, FTP Обмен через XML Банковские операции v8 v8::УФ 1cv8.cf Украина БУ Абонемент ($m)

Обработки формата обмена, которые производят чтение файлов выгрузки из КБ, через основную обработку от АББИ Украина для БУ 2.0 Обработка тестировалась на "Бухгалтерия для Украины, редакция 2.0. релиз (2.0.8.2)".

1 стартмани

09.05.2018    36202    155    zVORTEXz    35    

Обмен с СУФД (Федеральным казначейством) для Бухгалтерии 2.0 и 3.0

Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП2.0 БП3.0 Россия БУ Абонемент ($m)

Выгрузка-Загрузка СУФД (ФК) для Бухгалтерия 2.0 и 3.0, ПРОФ и КОРП.

1 стартмани

13.04.2018    44725    353    Vyatcheslav    150    

Удобная выгрузка зарплаты в формат CSV для Сбербанк Бизнес Онлайн (ЗУП 2.5) Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Самая удобная внешняя обработка для бухгалтера, не требует лишних действий! Выбрал документ и выгрузил в формате CSV для Сбербанк Бизнес Онлайн

10 стартмани

06.11.2015    47022    29    adinez    7    

Загрузка чеков из ФНС (Налоговой), отсканированных с помощью QR-кода, в 1С:Деньги

Внешние источники данных WEB Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Расширение для получения чеков со всеми товарами в чеке с сайта ФНС (Налоговой).

1 стартмани

19.03.2018    18770    23    semen_2008    4    

Инструменты бухгалтера: Подбор документов расчетов

Рабочее место Банковские операции Обработка документов Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка подбора документов расчетов в банковские и кассовые документы. Если стоит задача разнесения банковских выписок по конкретным расчетным документам, данная обработка облегчит её.

1 стартмани

07.03.2018    13533    14    Bazil    1    

Выгрузка начислений родительской платы в формате txt для СберБанка из БГУ 1.0

Обработка документов Банковские операции Обмен с банком Банковские операции v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Обработка формирует  реестр из документа "Начисление родительской платы" в текстовый документ для загрузки в Сбербанк Онлайн. Готова к работе. Программист для установки и работы не требуется.

1 стартмани

22.11.2017    17067    39    Denis_CFO    1    

Выгрузка в банк Уралсиб из БП 3.0 Промо

Обмен с банком Банковские операции Банковские операции v8 БП3.0 БУ Абонемент ($m)

Внешняя обработка для выгрузки зарплатной ведомости и зарплатных счетов сотрудников

2 стартмани

15.09.2015    17719    0    hawk    0    

Выгрузка ведомости перечислений на счета ЗУП 3.1 в клиент-банк (txt)

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка предназначена для выгрузки данных документа "Ведомость перечислений на счета" в текстовый файл, для последующей загрузки в программу типа "Клиент банка".

1 стартмани

22.11.2017    25634    124    gorsh157    3    

Сравнение и синхронизация баз УТ-БП

Обработка документов Анализ учета Банковские операции Кассовые операции Оптовая торговля Розничная торговля Банковские операции Кассовые операции Оптовая торговля Розничная торговля v8 БП3.0 УТ11 БУ УУ Абонемент ($m)

Обработка позволяет быстро синхронизировать документы в базах УТ и БП. Будет полезна для бухгалтеров, специалистов поддержки, программистов, руководителей. Тестировалась на конфигурациях Бухгалтерия предприятия, редакция 3.0 (3.0.52.39) и Управление торговлей, редакция 11 (11.3.4.93), платформа 8.3.10.2299.

2 стартмани

08.11.2017    13243    38    leossb    6    

Загрузка Классификатора Банков с сайта РосБизнесКонсалтинг

Обработка справочников WEB Банковские операции Банковские операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка классификатора банков в Бухгалтерию 3.0 из файта bnk.zip, скачанного с сайта РосБизнесКонсалтинг.

1 стартмани

06.10.2017    101375    305    nefeld    42    

Выгрузка в банк из "Камин" заработной платы Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 1cv8.cf БУ Абонемент ($m)

Выгрузку можно делать для 2 банков ВТБ и Уралсиб, уралсиб выгружает 2 вида файлов

2 стартмани

23.10.2014    26088    0    hawk    1    

Работа с интегрированным терминалом Сбербанка через утилиту upwin.exe

Обмен с банком Банковские операции Розничная торговля Банковские операции Розничная торговля v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Утилита UPWIN.exe от Сбербанка, коды команд для управления интегрированным банковским терминалом (управляемые формы, обычные под 8.1). Обработка на управляемых формах запускается под любой конфигурацией, обработка на обычных формах также запускается под любой конфигурацией на платформе от 8.1 и выше

1 стартмани

05.09.2017    32485    108    independ    20    

Универсальная конвертация счетов в IBAN и обратно (обычная и управляемая форма)

Универсальные обработки Обработка справочников Банковские операции Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

На пороге переходный период для внедрения номеров счетов в формате IBAN. Но если вы все пропустили - не беда, переход занимает пару минут! Читай далее, как это сделать...

1 стартмани

01.07.2017    16668    9    Xershi    6    

Выгрузка зарплаты в Сбербанк, формат csv, для ЗУП 3.1

Банковские операции Зарплата Обмен с банком Банковские операции Зарплата v8 ЗУП3.x Россия БУ Абонемент ($m)

Выгрузка зарплаты в Сбербанк из документа "Ведомость на выплату зарплаты в банк" в формате CSV для ЗУП 3.1

1 стартмани

17.05.2017    33074    198    shtinalex    8    

Выгрузка в Сбербанк Промо

Файловые протоколы обмена, FTP Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗКБУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Обработка для выгрузки списка лицевых счетов для зачисления заработной платы в формате DBF, согласно требованиям СБРФ

1 стартмани

31.01.2013    31096    134    alfaservice    7    

Проверка счетов IBAN Беларусь

Универсальные обработки Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

С 04.07.2017 в Беларуси вводится новая нумерация банковских счетов. Обработка поможет расчитать контрольную цифру, и проверить введенный счет на правильность. + Небольшое количество инфы по переходу

1 стартмани

11.05.2017    15012    3    GOshaSaveiko    15    

Групповая обработка банковских выписок для БП 2.0 и 3.0

Банковские операции Обработка документов Банковские операции v8 БП2.0 БП3.0 Россия БУ Абонемент ($m)

Данная обработка создана для оперативной обработки большого количества загруженных из Клиент-банка банковских выписок. Была создана по просьбе бухгалтеров и во много раз упростила и "убыстрила" им работу.

1 стартмани

20.04.2017    14054    53    Gipatalamus    7    

Загрузка операций по карте Сбербанка в 1С:Деньги Промо

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы Россия Абонемент ($m)

Обработка для импорта операций по карте Сбербанка в 1С:Деньги; Сегодня многие платят за покупки с помощью банковских карт. Особенно актуально если у вас зарплатная карта от Сбербанка и вы ведете учет личных финансов в программе 1С Деньги. В какой-то момент мне надоело коллекционировать чеки и я написал эту обработку. :) Надеюсь вам она тоже сэкономит личное время. UPD Добавлена версия для "Деньги 8, редакция 2.0 (2.0.18.6)"

1 стартмани

01.09.2013    33799    68    el-gamberro    33